Microsoft Excel | Гостевая книга
msoffice.nm.ru

Просмотр сообщения

← перейти к гостевой книге
Егор   5 апреля 2015, 01:57  ::
Помогите плиз. Задача следующая:
В результате выражения получаю число х, задано несколько интервалов формата z<=x<y, в зависимости от того в какой интервал попало число x, оно будет округляться по разным условиям (до сотых долей, десятых долей, единиц итд). Как прописать формулу?
« предыдущее . следующее »
Ответ 6 апреля 2015, 17:22
Вы можете использовать классический вариант с использованием функции =ЕСЛИ() или попробовать замутить, например, что-то вроде :

A1=101,123456789
B1=ОКРУГЛ(A1;ПРОСМОТР(A1;{0;100;200};{1;2;4}))