Microsoft Excel | Гостевая книга
msoffice.nm.ru

Всего сообщений: 9
Андрей Васильевич   20 сентября 2016, 19:09  ::
Очень рад, что случайно нашел свой ЛЮБИМЫЙ ИСЧЕЗНУВШИЙ САЙТ. Как всегда Вы на высоте. Только здесь нашел решение своего вопроса.Легко и просто. СПАСИБО !!!

Виктор   22 апреля 2016, 23:27  ::
Здравствуйте! Спасибо за структурированную информацию по EXCEL и VBA. Вы сделали очень-очень БОЛЬШУЮ РАБОТУ!!! На Вашем сайте можно найти ответы на любые вопросы по EXCEL и VBA. Но вот о создании макроса "Private Sub" я пока ничего не нашел. Подскажите, пожалуйста, где можно об этом почитать! С наилучшими пожеланиями творческих успехов! И с огромной благодарностью от простого пользователя (влюбленного в EXCEL и VBA)
Ответ 23 апреля 2016, 16:19
Если под термином <создание макроса> скрывается запись макроса (макрорекординг), то здесь всё просто - сначала Вы записываете свои действия, а затем, просто вручную добавляете Private.

Если же Вы уже выросли из макрорекордера, и создаёте макросы, набирая код непосредственно в редакторе VBA, то для создания приватной(личной) процедуры, достаточно вместо привычного Sub ИмяМакроса() сразу ввести Private Sub ИмяМакроса()

Андрей   25 января 2016, 23:15  ::
Ура-ура-ура! Сайт переехал и снова заработал! Пользуясь случаем выражаю глубочайшую благодарность создателям безусловно лучшего в рунете сайта, посвящённого VBA. Спасибо! Мы очень рады, что вы снова с нами.

Сергей   15 июня 2015, 00:40  ::
Добрый день. Помогите, пожалуйста, решить следующую задачку с текстом. В одной ячейке Excel находятся номера телефонов и сайт(ы) организации через запятую.
Пример одной ячейки: "(800) 555-55-50, (495) 957-57-21, www.sbrf.ru, www.sberbank.ru"
В следующей ячейке: "(495) 719-30-01, (495) 428-45-60, , +7 (495) 428-45-70, gazbez.ru"
итд.
Как разделить эти данные на два столбца: "Телефон(ы)" и "Сайт(ы)? Как можно раскидать???
Ответ 15 июня 2015, 21:29
Если последний сайт (на самом деле) начинается с www. то разделить можно с помощью формулы.
Если нет, то Вы можете выслать мне всю таблицу, в виде файла .xls (97-2003), чтобы можно было произвести разделение реальных данных.
Адрес для отправки - urllink@yandex.ru

Егор   5 апреля 2015, 01:57  ::
Помогите плиз. Задача следующая:
В результате выражения получаю число х, задано несколько интервалов формата z<=x<y, в зависимости от того в какой интервал попало число x, оно будет округляться по разным условиям (до сотых долей, десятых долей, единиц итд). Как прописать формулу?
Ответ 6 апреля 2015, 17:22
Вы можете использовать классический вариант с использованием функции =ЕСЛИ() или попробовать замутить, например, что-то вроде :

A1=101,123456789
B1=ОКРУГЛ(A1;ПРОСМОТР(A1;{0;100;200};{1;2;4}))

Антон   22 марта 2015, 17:25  ::
Этот сайт лучший из лучших по Экселю и VBA!

Владимир   26 сентября 2014, 16:36  ::
Чел, твой сайт реально мне помог!!!

Катя   4 июня 2014, 15:12  ::
Здравствуйте, Павел Юрьевич! Меня зовут Катя (издательство Skill.im). Недавно мы создали самый полный и качественный видео курс в Рунете по Excel 2013. Я бы хотела сделать Вам коммерческое предложение. Если Вам интересно, напишите мне на e-mail. Спасибо

msoffice   18 апреля 2014, 14:33  ::
Тест - лучшая проверка

В книге включена премодерация, ваше сообщение будет опубликовано только после проверки.

Написать сообщение

Имя:

E-mail (будет скрыт):

Текст (справка):


Число на картинке: